Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 20, 2025 - 15:39 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 20, 2025 - 11:00 UTC
Scheduled
We are sending this message to notify you of our schedules system maintenance on Sunday April 20th, from 13:00 to 18:00 CET (estimated).
During this scheduled maintenance, Trusted routes customers may experience intermittent failures. If you've got scheduled calls during this time window, we recommend you to delay them or to setup a global retry policy.
All other systems will be functional.
Posted Apr 18, 2025 - 07:15 UTC
This scheduled maintenance affected: Trusted Routes.