Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 09, 2026 - 13:00 UTC
Scheduled
We will run an extended disaster recovery test of our integration server. Flat file and (incoming) webhook integrations will be paused for a few hours. No data will be lost, and a few critical processes will be run in degraded mode.
Posted Jun 09, 2026 - 12:40 UTC
This scheduled maintenance affected: Interfaces (Flat file integration).